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1.   Introduction 

 

 

Thank you for your interest in the FM4-120L-S6E2HG FM4 S6E2H-Series Starter Kit. The FM4 

S6E2H-Series Starter Kit enables customers to evaluate and develop projects using the FM4 

device family. Flexible MCU 4 (FM4) is a portfolio of high-performance ARM® Cortex®-M4 MCUs 

that includes hardware support for digital signal processing and floating-point operations, 

designed for safety-critical, industrial systems and home appliance applications. There are 

multiple series of device families in this portfolio. The S6E2C-Series, S6E2H-Series and S6E2G-

Series are few of the prominent series of device families. This kit uses a device from the S6E2H-

Series. 

Devices in the S6E2H-Series are highly integrated 32-bit microcontrollers with high performance 

at a competitive cost. This series is based on the ARM® Cortex®-M4 processor, including 

floating point instructions, with on-chip flash memory and SRAM. The series has peripherals 

such as motor control timers, A/D converters, and communications interfaces like CAN, UART, 

CSIO, I2C and LIN. The S6E2H-Series of FM4 devices offers up to a 160-MHz CPU, 512 Kbytes 

Main Flash, 32 Kbytes Work Flash, 64KB SRAM, 100 GPIOs, 24 digital peripherals and 2 analog 

peripherals. 

The FM4 S6E2H-Series Starter Kit routes all pins out, which provides limitless options for 

application development. It is intended to aid the customer to evaluate the featured peripherals 

of the S6E2H-Series. In order to properly enable our customers, the FM4 S6E2H-Series Starter 

Kit is aligned to our low cost development systems, aligning this kit with our successful line of 

Starter Kits in form, price and flexibility.  
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1.1   Kit Contents 

The FM4 S6E2H-Series Starter Kit contains the following, as shown in Figure 1-1. 

 FM4 S6E2H-Series Starter board 

 USB Standard-A to Micro-B cable 

 Quick Start Guide 

 

Figure 1-1: Kit Contents 

 

Inspect the contents of the kit; if you find any part missing, contact your nearest Cypress sales 

office for help: www.cypress.com/support.  

  

http://www.cypress.com/support
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1.2   Board Details 

Figure 1-2: FM4 S6E2H-Series Starter Kit Markup 
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1. Cypress FM4 MCU S6E2HG6A0J 

2. Non-Maskable Interrupt pin (NMIX) switch (SW3) 

3. User button (SW2) 

4. Reset LED 

5. Reset button 

6. MB9AF312K Programmer and Debugger (CMSIS-DAP) 

7. 20-pin JTAG interface (CN2) 

8. VBUS selection jumper for CMSIS-DAP (J2) 

9. Programmer and debugger enable jumper (J3) 

10. Programming mode jumper of MB9AF312K (J5) 

11. Jumper to connect SW3 to NMIX (J10) 

12. On-board voltage select (J15) 

13. Select power from CMSIS-DAP (J7) 

14. Select power from peripheral (J6) 

15. Power supply LED 

16. RGB LED 

17. Potentiometer (R11) 

18. Jumper for Pin56 multifunction select (J21) 

19. Jumper to connect S6E2HG SIN0 to CMSIS-DAP (J19) 

20. Programming mode (MD0) jumper of S6E2HG (J18) 

21. Battery connector (CN1) 

22. Jumper to connect S6E2HG SOT0 to CMSIS-DAP (J20) 
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1.3   Jumper and Connector 

Table 1-1: Connector Description 

Connector Description 

CN1 Battery connector 

CN2 20-pin JTAG interface 

CN3 USB port of CMSIS-DAP 

CN5 SD card interface 

 

Table 1-2: Jumper Description 

Jumper Function Setting 

J2 VBUS detection of CMSIS-DAP 

Used for VBUS detection function (pin 

60) of MB9AF312K on board 

Open: For on-board voltage is 3.3V 

Closed: For on-board voltage is 5.0V 

J3 Programmer and Debugger select Open: Enable CMSIS-DAP unit 

Closed: Disable CMSIS-DAP unit 

J5 Pull down the MD0 of MB9AF312K Open: Run mode 

Closed: Serial programming mode  

J6, J7, 

J8 

Power supply source select 

Select only one power source! 

 

Closed J6: Powered by peripheral at J16 

Closed J7: Powered by CN3 (USB port of CMSIS-DAP) 

Closed J8: Powered by CN2 (20-pin JTAG interface) 

J10 SW3 connect Open: SW3 is disconnected from the S6E2HG 

Closed: SW3 is connected to the S6E2HG 

J15 On-board voltage select Pin1 to Pin2: Sets MCU voltage at 3.3V  

Pin 2 to Pin3: Sets MCU voltage at 5V 

J18 Pull down the MD0 of S6E2HG Open: Run mode 

Closed: Serial programming mode  

J19 CMSIS-DAP virtual COM connect Open: SIN0_0 is disconnected from CMSIS-DAP  

Closed: SIN0_0 is connected with CMSIS-DAP 

J20 CMSIS-DAP virtual COM connect Pin1 to Pin2: SOT0_0 is connected with CMSIS-DAP 

Pin2 to Pin3: Pull down the P22 of MB9AF312K 

J21 MD1/PE0 function select Pin1 to Pin2: Pull down MD1 (Programming-Mode) 

Pin2 to Pin3: PE0 drives the blue LED 
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1.4   Getting Started 

This guide will help you get started with the FM4 S6E2H-Series Starter Kit: 

 The Installation and Test Operation chapter describes the kit installation and test 

operation. This includes the CMSIS-DAP driver to enable the CMSIS-DAP debugger, 

Serial Port Viewer Tool to view the serial port communication, Flash MCU programmer 

and Flash USB Direct programmer to program the hex files on the device. 

 The Hardware chapter describes the major features of the FM4 S6E2H-Series Starter 

Kit and functionalities such as CMSIS-DAP debugger, RGB LED, and buttons. 

 The Software Development chapter describes the available software resources and 

tools, and how to create a project based on the Peripheral Driver Library (PDL). 

 The Appendix provides the kit schematics, and the bill of materials (BOM). 

1.5   Additional Learning Resources 

Cypress provides a wealth of data at www.cypress.com to help you to select the right MCU 

device for your design, and quickly and effectively integrate the device into your design. The 

following is an abbreviated list for FM4 family resources: 

 Overview: S6E2H-Series fact sheet 

 Device Selector : Microcontroller Select Guide 

 Datasheets: S6E2H-Series datasheet and Handling precautions. 

 FM4 Peripheral Manual: Main Section, Communication Macro Section, Analog Macro 

Section, Timer Section. 

The documents listed above can be accessed from the kit’s webpage at  

www.cypress.com/FM4-120L-S6E2HG.  

1.6   Technical Support 

For assistance, visit Cypress Support or contact customer support at +1(800) 541-4736 Ext. 2 

(in the USA) or +1(408) 943-2600 Ext. 2 (International). 

  

http://www.cypress.com/
file:///C:/Users/naik/Desktop/Hestia/www.cypress.com/FM4-120L-S6E2HG
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1.7   Acronyms 

Table 1-3. Acronyms Used in this Document 

Acronym Description 

ADC Analog-to-Digital Converter 

CMSIS-DAP Debug Access Port 

GPIO General Purpose Input/Output 

I2C Inter-Integrated Circuit 

IDE Integrated Development Environment 

LDO Low Drop Out (voltage regulator) 

LED Light-Emitting Diode 

INT Interuppt 

RGB Red Green Blue 

JTAG Joint Test Action Group 

MFS Multi Function Serial 

PDL Peripheral Driver Library 

SWD Serial Wire Debug 

UART Universal Asynchronous Receiver Transmitter 

USB Universal Serial Bus 
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2.   Installation and Test Operation 

 

 

This chapter describes the steps to install the software tools on a PC for using the FM4  

S6E2H-Series Starter Kit. After successful installation, the user can run pre-programmed test 

code on the device. 

2.1   Install Software 

Follow the steps below to install the FM4 S6E2H-Series Starter Kit software: 

1. Download the FM4 S6E2H-Series Starter Kit installer from the webpage 

www.cypress.com/FM4-120L-S6E2HG. The Kit software is available for download in three 

formats.  

 FM4 S6E2H-Series Starter Kit Complete Setup: This installation package contains the 

files related to the kit, including the Documentation, Hardware, Firmware, Software tools 

and drivers. However, it does not include the Windows Installer or Microsoft .NET 

framework packages. If these packages are not installed on your computer, the installer 

directs you to download and install them from the Internet. 

 FM4 S6E2H-Series Starter Kit Only: This executable file installs only the kit contents, 

which include kit code examples, hardware files, and user documents. This package can 

be used if all the software prerequisites (listed in step 7) are already installed on your 

PC. 

 FM4 S6E2H-Series Starter Kit DVD ISO: This file is a complete package, stored in a 

DVD-ROM image format, which you can use to create a DVD or extract using an ISO 

extraction program such as WinZip® or WinRAR. The file can also be mounted like a 

virtual CD/DVD using virtual drive programs such as Virtual CloneDrive and MagicISO. 

This file includes all the required software, utilities, drivers, hardware files, and user 

documents. 

2. If you have downloaded the ISO file, mount it as a virtual drive. Extract the ISO contents if 

you do not have a virtual drive to mount the ISO file. Double-click cyautorun.exe in the 

root directory of the extracted content or the mounted ISO if “Autorun from CD/DVD” is not 

enabled on the PC. The installation window will appear automatically. 

Note: If you are using the “Kit Complete Setup” or “Kit Only” package, then go to step 4 for 

installation. 

  

http://www.cypress.com/FM4-120L-S6E2HG
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3. Click Install FM4-120L-S6E2HG to start the kit installation, shown as Figure 2-1. 

Figure 2-1: Kit Installation Window 

 

4. Select the folder in which you want to install this package or use the default folder and 

click Next. 

5. Choose the Typical, Custom, or Complete installation type (select 'Typical' if you do not 

know which one to select) in the Product Installation Overview window, as shown in  

Figure 2-2. Click Next after you select the installation type. 

Figure 2-2: Product Installation Overview 

 

6. Read the License agreement and select I accept the terms in the license agreement to 

continue with installation.  
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7. When you click Next, the FM4 S6E2H-Series Starter Kit installer automatically installs the 

required software, if it is not present on your PC. Following are the required software and 

driver:  

 FM Universal Peripheral Driver Library (PDL) 

 Serial Port Viewer  

 FLASH USB DIRECT Programmer  

 FLASH MCU Programmer  

 CMSIS-DAP driver  

8. When the installation begins, a list of packages appears on the installation page. A green 

check mark appears next to each package after successful installation. 

9. If you are an un-registered user either enter your contact information or select the check 

box Continue without Contact Information. If you are a registered user, then the 

installation procedure will not request you to enter the contact information. Click Finish to 

complete the kit installation. 

Note: Ensure that the check boxes Extract Example Projects and Extract FM PDL 2.0 

are selected. 

Figure 2-3: Launch the Contents 
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10. View the documents and select the folder in which you want to extract the FM Peripheral 

Driver Library (PDL) and example projects or leave it as default. Click Install. 

Figure 2-4: Extract the Example Projects 

 

11. Click Close to finish the extraction. 

After the installation is complete, the documents and hardware files are available at the following 

default location:  

Windows OS (64-bit): C:\Program Files (x86)\Cypress 

\FM4 S6E2H-Series Starter Kit  

Windows OS (32-bit): C:\Program Files\Cypress\FM4 S6E2H-Series Starter Kit 

The Peripheral Driver Library (PDL) will be extracted to this default directory: 

C:\Users\<User Name>\My Documents\Cypress\FM_PDL_2.0.1 

And, the example projects will be extracted to this default directory: 

C:\Users\<User Name>\My Documents\Cypress 

\FM4 S6E2H-Series Starter Kit_Ver01 

In the rest of the document, the following directory is termed as <User_Directory>: 

C:\Users\<User Name>\My Documents\Cypress 

2.2   Uninstall Software 

The software can be uninstalled using one of the following methods:  

 Go to Start > All Programs > Cypress > Cypress Update Manager and select the 

Uninstall button that corresponds to the kit software.  

 Go to Start > Control Panel > Programs and Features for Windows 7 or Add/Remove 

Programs for Windows XP; select the Uninstall button. 

Note: Uninstalling the Kit software will not remove the FM PDL 2.0 and FM4 S6E2H Series 

Starter Kit Example Projects from <User_Directory>. 

  



 Installation and Test Operation 

 

FM4 S6E2H-Series Starter Kit Guide, Doc. No. 002-11387 Rev. ** 15 

 

2.3   Test Operation 

The FM4 S6E2H-Series Starter Kit has been pre-programmed with a test demo code, which 

helps you to test all on-board features. The Motorola s-record file, tp_fm4-120l-s6e2hg.srec, is 

provided in the following directory and can be programmed on the MCU by using the FLASH 

MCU Programmer. 

<User_Directory>:\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\Test_Demo_Code 

2.3.1   Run the Test Demo 

Follow the instructions to run the test demo code. 

1. Ensure the jumpers J7, J10 and J19 are closed. Close Pin 1 and Pin 2 of J15 and J20. 

Close Pin2 and Pin3 of J21 and connect CN3 to a PC using the USB cable provided. 

Figure 2-5: Power the Board from CN3 

 

2. Ensure the power LED (LED5) is on and the LED3 blinks with a breathing effect. The RGB 

LED (LED2) will alternately flash red, green, and blue. 

3. If not already launched, then launch the Serial Port Viewer from the start menu under  

All Programs > Cypress > Serial Port Viewer. 
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5. Click on the Serial Port Viewer icon in the task bar and select the FM-Link/CMSIS-DAP 

Cypress FM Communications Port.  

Figure 2-6: FM-Link/CMSIS-DAP Cypress FM Communications Port 

 

6. Select the baud rate 115200, and click the Disconnect button to connect the board. 

Figure 2-7: Select the Baud Rate 

 

7. Press the Enter key on your keyboard to run the test procedure. Key in the option number 

to run the test and press the Enter key to complete the test. 

Figure 2-8: Test Procedure 
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8. For example, key in 1 to test the Red LED. 

Figure 2-9: Red LED Test-1 

 

9. Press the Enter key to complete the Red LED test. The terminal window will display 

TESTED. 

Figure 2-10: Red LED Test-2 
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2.3.2   Test Procedure Explanation 

This section explains the test procedure. This test procedure is based on the Serial Port Viewer. 

The user has to key-in the test procedure number displayed on the menu to run the test 

procedures and then press the Enter key on the PC to complete the test. The firmware on the 

board will run the test procedure and display the results. There are eight test procedures. A short 

description of each test procedure is given below: 

 Red LED (RGB LED) Test: This procedure will test whether red LED works normally. 

Key in 1 to run the test procedure and the red LED will blink. Then press the Enter key 

on the PC to complete the test and TESTED will be displayed next to the test. 

Figure 2-11: Red LED Test 

  

 

 Green LED (RGB LED) Test: This procedure will test whether green LED works 

normally. Key in 2 to run the test procedure and the green LED will blink. Then press the 

Enter key on the PC to complete the test and TESTED will be displayed in the console. 

Figure 2-12: Green LED Test 
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 Blue LED (RGB LED) Test: This procedure will test whether blue LED works normally. 

Key in 3 to run the test procedure and the blue LED will blink. Then press the Enter key 

on the PC to complete the test. TESTED will be displayed as shown in Figure 2-13. 

Figure 2-13: Blue LED Test 

  

 

 SW2 User Key Test: This procedure is to test switch SW2. Key in 4, and then press 

SW2 on the starter board. The RGB LED (LED2) will glow green while SW2 is held down. 

Release SW2 and press the Enter key to complete the test. It will display OK. 

Figure 2-14: SW2 User Key Test 
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 SW3 User Key Test: This procedure is to test switch SW3. Key in 5, and then press 

SW3 on the starter board. The RGB LED (LED2) will glow green while SW3 is held down. 

Release SW3 and press Enter to complete the test. It will display OK. 

Figure 2-15: SW3 User Key Test 

  

 

 Potentiometer Test: This procedure tests the potentiometer. Key in 6 and "Turn Pot 

clockwise/anti-clockwise" appear in the serial port viewer window depending on the 

potentiometer’s (R11) current position. When the potentiometer is turned clockwise from 

the min to the max position, RGB LED (LED2) color changes from red to green to blue. 

When turned anticlockwise, LED color varies from blue to green to red. 

 Figure 2-16: Potentiometer Test 
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 SD Card Test: This procedure tests the SD Card. Key in 7 and press the Enter key. If 

an SD Card is found in the SD card slot (CN5) and read successfully, the console will 

display OK. If an SD Card is not found in the slot, the console will display Fail.  

Figure 2-17: SD Card Test 

  

 

 Sub Clock Test: This procedure will test whether the sub clock is at 32.768 KHz or not. 

Key in 8 and press the Enter key, the main routine will shift the system clock to the sub 

clock, and then shift back to main clock after the sub clock is confirmed to be running at 

32.768 KHz. It displays OK if the sub clock is running at 32.768 KHz otherwise it will 

display Fail.  

Figure 2-18: Sub Clock Test 
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3.   Hardware 

 

 

This chapter describes the features and hardware details of the FM4 S6E2H-Series Starter Kit. 

3.1   System Block Diagram 

Figure 3-1 shows the block diagram of the FM4 S6E2H-Series Starter Kit. 

Figure 3-1: System Block Diagram 

 

3.2   Hardware Features 

 Cypress FM4 S6E2HG MCU 

 On-board ICE (CMSIS-DAP compatible) 

 SD card interface 

 All pins interface 

 Reset LED  

 Potentiometer 

 RGB LED 

 User buttons to generate interrupt (INT) and Non-Maskable interrupt (NMIX) 
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 Reset button 

 20-pin JTAG interface 

 Selectable on-board voltage (3.3 V or 5.0 V) 

3.3   Hardware Details 

3.3.1   FM4 Series MCU 

The FM4 S6E2HG MCU is a family of highly integrated 32-bit microcontrollers dedicated for high 

performance embedded controllers at competitive price. 

This series is based on the ARM® Cortex®-M4 processor with on-chip flash memory and SRAM, 

and has peripherals such as motor control timers, A/D converters, and communication interfaces 

like CAN, UART, CSIO, I2C, and LIN.  

3.3.2   User Button and LED 

The FM4 S6E2H-Series Starter Kit features two user buttons and a 3-color LED. The LED and 

switches are connected to the S6E2HG MCU device via pins listed in Table 3-1.  

Table 3-1: Button and LED 

Pin Number Port Peripherals External Device 

108 P68 SCK3_0,TIOB7_2, INT00_2 SW2 

116 P60 SCK5_0,TIOA2_2,NMIX,MRDY_0,WKUP0 SW3 

82 P27 TIOA6_2, INT02_2, RTO05_1 LED2 – Red 

22 P38 INITX LED2 – Green 

56 PE0 MD1 LED2 – Blue 

 

Pin 56 is used to drive the blue LED; it is also connected to MD1 pin which is used for the serial 

programming mode setting. Jumper J21 can be used to switch the functions. Table 3-2 shows 

the configuration. 

Table 3-2: J21 Configuration 

Jumper-J21 Port Function 

Close 2~3 PE0 Drive the blue LED 

Close 1~2 MD1 Serial programming mode 
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3.3.3   SD Card Interface 

CN5 is an SD card interface connected with the SDIO macro of the S6E2HG device. This SD 

card interface supports full function of the SDIO including data transmission, card detection and 

write protection. 

Figure 3-2: SD Card Circuit 

 

The pin arrangement of the SD card is shown in Figure 3-3. 

 

Figure 3-3: Pin Arrangement of SD Card Interface 

 

  

SD Card 
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Table 3-3 shows the signals of the SD card interface. 

Table 3-3: Signals of SD Card Interface 

Pin No. Pin Name Type Description 

1 DAT2 I/O Data 

2 DAT3 I/O Data 

3 CMD I/O Data 

4 C/D I/O Card detect 

5 VSS1 power Power supply ground 

6 VDD power Power supply 

7 CLK I Clock  

8 VSS2 power Power supply ground 

9 DAT0 I/O Data 

10 DAT1 I/O Data 

11 W/P O Write protect detect 

 

3.3.4   CMSIS-DAP 

The FM4 S6E2H-Series Starter Kit features an on-board CMSIS-DAP module to enable 

programming and debugging of the FM4 S6E2HG MCU. The CMSIS-DAP firmware solution 

supports full JTAG configuration and a two-wire Serial Wire Debug (SWD) interface. 

The CMSIS-DAP module can also power the FM4 S6E2H-Series Starter kit via the CN3 

connector.  

Figure 3-4: CMSIS-DAP Circuit  

 

CMSIS-DAP 
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3.3.5   JTAG 

The FM4 S6E2H-Series Starter Kit provides an interface, CN2, to connect an external 

programmer for programming the FM4 S6E2HG MCU or for connecting a third-party debugging 

tool. CN2 is a standard ARM 0.1’’ 10*2-pin Cortex debug connector. 

Figure 3-5: 10-pin JTAG I/F 

 

3.3.6   Potentiometer 

The FM4 S6E2H-Series Starter Kit has a potentiometer with resistance value ranging from 0 to 

10 kΩ. The middle terminal is connected to the ADC channel AN18. 

Figure 3-6: Potentiometer 

 

  

JTAG 

Potentiometer 
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3.3.7   Expansion Port 

The FM4 S6E2H-Series Starter Kit provides two sets of expansion ports which route all the MCU 

pins. The user can access all pins of the S6E2HG device from these ports. Figure 3-7 shows the 

details. 

Figure 3-7: Expansion Port 
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4.   Software Development 

 

 

This chapter provides information about the available software resources supporting the 

S6E2HG device and FM4 S6E2H-Series Starter kit.  

4.1   Tool Options 

The FM4 S6E2H-Series is supported by several third party tools/IDEs, and the user can choose 

their preferred tool for development. Any one of below listed IDEs can used for opening and 

building the example projects packaged with this kit:  

 IAR Embedded Workbench for ARM  

 Keil ARM RealView® Microcontroller Development System  

Download evaluation versions of these tools from the vendor’s website. A full license may be 

required to build or debug some of the example projects. For detailed information on using the 

tools, see the documentation in the Help section of the tool chain or the website of the tool’s 

supplier. 

4.1.1   Build an Example Project with IAR IDE 

The following steps describe how to open, build, and run an example project in the IAR IDE. 

The s6e2hg_adc is one example project that is available after a successful installation. 

1. Launch IAR Embedded Workbench IDE V7.40.5.9739 (or later).  
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2. Click File > Open > Workspace and select the workspace file s6e2hg_adc.eww from 

<User_Directory>:\ FM4 S6E2H-Series Starter Kit_Ver01 

\Firmware\Demo Projects\s6e2hg_adc\IAR 
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3. Click Project > Rebuild All to build the project. 

 

 

4. Make sure the jumpers on the FM4 S6E2H-Series Starter board are placed according to 

Table 4-1. 

Table 4-1: Debugging Jumper Settings 

Jumper Position Description 

J2 Open Sets MB9AF312K to 3.3V. 

J3 Open Sets MB9AF312K (CMSIS-DAP) in run mode. Power from CMSIS-DAP (CN3) 

J7 Closed Sets S6E2HG (CMSIS-DAP) in run mode. 

J10 Closed Sets SW3 user button connected. 

J15 Pin1 to Pin2 Sets S6E2HG to 3.3V. 

J19 Close CMSIS-DAP virtual COM connection 

J20 Pin1 to Pin2 CMSIS-DAP virtual COM connection 

J21 Pin2 to Pin3 PE0 drives blue LED 

5. Connect the USB cable to the CN3 port. 

6. Observe that Power LED (LED5) is glowing green. 

7. Click the Download and Debug icon in the tool bar, use Shortcut Crtl+D, or choose 

Project > Download and Debug to start downloading and debugging. 

 

Note: When downloading the code example into the board, if you get a following warning: 

"Skipping flash loading pass because there is no data in the designated range: 

0x200C0000-0x200C7FFF", you can safely ignore it. 

The S6E2HG processor includes two banks of flash, the main flash and a smaller work 

flash at address 0x200C0000. The code examples do not use the work flash. However, the 

debugger memory map includes the work flash, as it should. In effect, the IAR IDE tells you 

the code example doesn't use the work flash. That's correct, and not a problem. 
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8. Click the Run icon to run the program once it is downloaded successfully. 

 

Refer to the Example Projects section for more details on example projects. 

9. Click the Stop icon to stop the program. 

 

For more information about the IAR Embedded Workbench IDE, please click Help from within 

the tool. 

4.1.2   Build an Example Project with Keil µVision IDE 

The following steps describe how to open, build and run an example project in Keil µVision IDE. 

Before doing this, please check the availability of the flash loader file of the S6E2HG device 

(S6E2HG4X0A.FLM & S6E2HG6X0A.FLM) in this directory: 

<Keil_Install_Directory>:\ARM\flash. 

If the flash loader files are not there, copy them to the above folder from: 

<User_Directory>:\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\<Project>\ARM\flashloader\ 

The s6e2hg_adc is one example project that is available after a successful installation. 

1. Launch Keil µVision IDE v5.16a (or later). 

2. Click Project > Open Project and select the workspace file s6e2hg_dac.uvprojx from 

<User_Directory>:\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_adc\ARM. 
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3. Click the Build icon to build this project. 

 

4. Make sure the jumpers on the FM4 S6E2HG-Series Starter board are placed according to 

Table 4-2. 

Table 4-2: Debugging Jumper Settings 

Jumper Position Description 

J2 Open Sets MB9AF312K to 3.3V. 

J3 Open Sets MB9AF312K (CMSIS-DAP) in run mode. Power from 

CMSIS-DAP (CN2) 

J7 Closed Sets S6E2HG in run mode. 

J10 Closed Sets S6E2HG user module 

J15 Pin1 to Pin2 Sets S6E2HG to 3.3V. 

J19 Closed CMSIS-DAP virtual COM connection 

J20 Pin1 to Pin2 CMSIS-DAP virtual COM connection 

J21 Pin2 to Pin3 PE0 drives blue LED 

 

5. Connect the USB cable to the CN3 port. 

6. Observe that Power LED (LED5) is glowing green. 

7. Click the Debug icon, use shortcut Crtl+F5, or choose Debug > Start/Stop Debug 

Session to start downloading and debugging. 

 

8. Click Run to run the program once it is downloaded successfully. 

 

9. Click Stop to stop the program when you want. 

 

For more information about the Keil µVision IDE, please click Help from within the tool. 
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4.2   Example Projects 

The FM4 S6E2H-Series Starter Kit includes twelve example projects to help the user get a quick 

start with the S6E2HG device. The example projects are located in this directory:  

<User_Directory>:\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects 

These examples listed in the Table 4-3 are based on the Peripheral Driver Library (PDL). The 

PDL provides APIs for initializing and operating on-chip peripherals. PDL documentation is 

available at: 

<User_Directory>:\FM_PDL_2.0.1\doc 

Use either IAR Embedded Workbench v7.40.5.9739 (or later) or Keil µVision IDE v5.16a (or later) 

to open these example projects. 

Table 4-3: Example Projects 

# Projects Title/Description 

1 s6e2hg_adc 

Title: Analog-to-Digital Converter 

Description: This project demonstrates the analog to digital conversion of the S6E2HG 

device. This example sets the ADC to channel 18 in single conversion mode with 

interrupt enabled. ADC channel 18 is connected to a potentiometer. The conversion is 

started using a software trigger. When an ADC conversion is completed, the interrupt 

callback function is called, it reads the result data and prints it to UART0. Refer to 

section AD Converter for details. 

2 s6e2hg_bt_pwm 

Title: Base Timer 

Description: This project demonstrates the base timer operation of the S6E2HG 

device. This project configures a base timer in PWM mode to generate a PWM 

sequence. The PWM outputs from TIOA6_2 which drives the red LED of LED2. The 

PWM duty cycle is updated every 1ms by another base timer to produce a breathing 

LED effect. 

3 s6e2hg_dma 

Title: Direct Memory Access (DMA) 

Description: This project demonstrates DMA operation of the S6E2HG device. This 

example shows how to use DMA for software block transfer. In this example DMA 

channel 0 is used to transfer the contents of an array to another array using software 

block transfer. After the transfer a callback function is executed, which sets a DMA 

operation finished flag. Refer to section Direct Memory Access (DMA) for details. 

4 s6e2hg_ext_int 

Title: External Interrupt 

Description: This project demonstrates the external interrupt operation of the S6E2HG 

device. SW2 key press is detected by the external interrupt. Pressing the SW2 key on 

the board will change the color of RGB LED (LED2) from red to green to blue.  

5 s6e2hg_flash 

Title: Flash Write 

Description: This project demonstrates the flash writing operation of the S6E2HG 

device. A specific set of four values each of four bytes in size will be written into a 

specific address location in the flash memory. Refer to section Flash Write for the 

details. 
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# Projects Title/Description 

6 s6e2hg_gpio 

Title: GPIO 

Description: This project demonstrates the GPIO operations of the S6E2HG device by 

driving an LED. Pin P38 sinks current from the green LED of the RGB LED (LED2). Pin 

P38 will output a pulse sequence to blink the LED continuously. 

7 s6e2hg_mfs_uart 

Title: Multi-function Serial Interface 

Description: This project demonstrates the UART communication of the S6E2HG 

device. This program enables the MFS0 as a UART to communicate with the CMSIS-

DAP. The CMSIS-DAP serves as the bridge between the MCU and the PC. Refer to 

section UART Communication for details. 

8 s6e2hg_mft_frt 

Title: Multi-function Timer 

Description: This project demonstrates the multi-function timer (MFT) operation of the 

S6E2HG device. This example demonstrates the access of FRT (Free Run Timer) in 

Up/Down-count mode with peak/zero match interrupt. The blue LED (RGB LED2) will 

turn on/off when peak/zero match interrupt occurs.  

9 s6e2hg_rtc 

Title: Real Time Clock  

Description: This project demonstrates the RTC operation of the S6E2HG device. The 

program enables the RTC in calendar mode, and sends out the current calendar data 

through UART0. The calendar starts from 2015/9/30 23:59:01 Wednesday. The 

calendar data will be displayed in the Serial Port Viewer window. When time reaches 

"2015-10-01 00:00:00", the Serial Port Viewer window displays ‘alarm occurs’ 

message, and at the same time, RGB LED2 starts blinking. A new time "2015-10-01 

09:30:00" is set. 

10 s6e2hg_sleep_mode 

Title: Sleep Mode 

Description: This project demonstrates the sleep mode operation of the S6E2HG 

device. The MCU will enter sleep mode after blinking the green LED five times. It can 

be woken up by pressing SW3. After wakeup, the green LED will turn on. Refer to 

section Sleep Mode for the details. 

11 s6e2hg_sw_wdt 

Title: Software Watchdog 

Description: This project demonstrates the operation of the S6E2HG watchdog by 

considering two different situations when the watchdog is enabled: a) when the 

watchdog is fed and b) when the watchdog is not fed. If the watchdog is enabled and is 

fed in time, the program will run normally, and the RGB LED will blink green. If the 

watchdog is enabled and not fed in time, the device will reset, and the green LED will 

remain ON continuously. Refer to section Software Watchdog for the details. 

12 s6e2hg_wc 

Title: Watch Timer 

Description: This project demonstrates the Watch Timer function of the S6E2HG 

device. The Watch Timer generates an interrupt every second. In the interrupt service 

routine, pin P38 will drive the RGB LED (LED2) to blink green. 
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4.2.1   AD Converter 

4.2.1.1 Project Description 

This project demonstrates the Analog-to-Digital conversion of the S6E2HG device. This example 

sets the ADC channel 18 in single conversion mode with interrupt enabled. ADC channel 18 is 

connected to a potentiometer. The conversion is started using a software trigger. When ADC 

conversion is completed, the interrupt callback function is called, it reads the result data and 

prints it to UART0. 

4.2.1.2 Hardware Connection 

No specific hardware connections are required for this project. All connections are hardwired on 

the board. 

4.2.1.3 Verify Output 

1. Power the FM4 S6E2HG-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 

2. Open the project file in IAR Embedded Workbench or Keil µVision IDE from the following 

directory on your PC: 

 IAR project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_adc\IAR\s6e2hg_adc.eww. 

 Keil project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_adc\ARM\s6e2hg_adc.uvprojx. 

3. Build the project and download the code into the S6E2HG device. 

4. Run the Serial Port Viewer, set the baud rate as 115200, and click the Disconnected 

button to connect the board with PC, as described in section Run the Test Demo. 

Figure 4-1: Select the Baud Rate 
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5. Run the program and the ADC value will be displayed in the Serial Port Viewer window. 

Figure 4-2: ADC value 

 

6. Turn the potentiometer, the ADC values will change accordingly. 

4.2.2   Direct Memory Access (DMA)  

4.2.2.1 Project Description 

This project demonstrates DMA operation of the S6E2HG device. The program configures DMA 

to move the data from au32SourceData (source array) to au32DestinationData (destination 

array), and then compares the content of the arrays to verify the data. 

4.2.2.2 Hardware Connection 

No specific hardware connections are required for this project. All connections are hardwired on 

the board. 

4.2.2.3 Verify Output 

4.2.2.3.1 Instructions for IAR Embedded Workbench 

1. Power the FM4 S6E2H-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 

2. Open the project file in IAR Embedded Workbench from the following directory on your 

PC: 

 IAR project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_dma\IAR\s6e2hg_dma.eww. 

3. Build the project and download the code into the S6E2HG device. 
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4. Open Watch1 window from View-> Watch. 

 

5. Add the arrays au32SourceData and au32DestinationData in Watch1 window. 

 

6. Run the program for a while (>10 seconds). 

7. Stop the program and check the arrays mentioned above. The Program Counter (PC) will 

stop at the routine as shown below which means the content of the arrays are the same. 

You can also verify the content of the arrays in the watch window. 

 

4.2.2.3.2 Instructions for Keil µVision IDE 

1. Power the FM4 S6E2H-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 

2. Open the project s6e2hg_dma in Keil µVision IDE from the following directory on your PC: 

 Keil project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_dma\ARM\s6e2hg_dma.uvprojx. 

3. Build the project and download the code into the S6E2HG device. 
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4. Open Watch1 window from View->Watch Windows. 

 

5. Add the arrays au32SourceData and au32DestinationData in Watch1 window. 

 

6. Run the program for a while (>10 seconds). 

7. Stop the program and check the arrays mentioned above. The Program Counter (PC) will 

stop at the routine as shown below which means the content of the arrays are the same. 

You can also verify the content of the arrays in the watch window. 

 

4.2.3   Flash Write 

4.2.3.1 Project Description 

This project demonstrates the flash writing operation of the S6E2HG device. A specific set of 

four values each of four bytes in size will be written into a specific address location in the flash 

memory. 

4.2.3.2 Hardware Connection 

No specific hardware connections are required for this project. All connections are hardwired on 

the board. 

4.2.3.3 Verify Output 

4.2.3.3.1 Instructions for IAR Embedded Workbench 

1. Power the FM4 S6E2H-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 
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2. Open the project file in IAR Embedded Workbench from the following directory on your 

PC: 

 IAR project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_flash\IAR\s6e2hg_flash.eww. 

3. Build the project and download the code into the S6E2HG device. 

4. Open the memory window from the View > Memory. Enter 0x00070000 in the Go to table 

and press the Enter Key on your PC. 

   

5. Run the program for a while (>10 seconds). 

6. Stop the program and check the content of 0x00070000 in flash. 

 

4.2.3.3.2 Instructions for Keil µVision IDE 

1. Power the FM4 S6E2H-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 

2. Open the project s6e2hg_flash in Keil µVision IDE from the following directory on your PC: 

 Keil project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_flash\ARM\s6e2hg_flash.uvprojx. 

3. Build the project and download the code into the S6E2HG device. 
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4. Open the Memory1 window from the View > Memory Windows. Enter 0x00070000 in the 

Address table and press the Enter Key on your PC. 

   

5. Run the program for a while (>10 seconds). 

6. Stop the program and check the content of 0x00070000 in the flash. 

 

4.2.4   UART Communication 

4.2.4.1 Project Description 

This project demonstrates the UART communication of the S6E2HG device. This program 

enables the MFS0 as a UART to communicate with the CMSIS-DAP. The CMSIS-DAP serves 

as the bridge between the MCU and the PC. 

4.2.4.2 Hardware Connection 

No specific hardware connections are required for this project. All connections are hardwired on 

the board. 

4.2.4.3 Verify Output 

1. Power the FM4 S6E2H-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 

2. Open the project file in IAR Embedded Workbench or Keil µVision IDE from the following 

directory on your PC: 

 IAR project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_mfs_uart\IAR\s6e2hg_mfs_uart.eww. 

 Keil project:<User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_mfs_uart\ARM\s6e2hg_mfs_uart.uvprojx. 

3. Build the project and download the code into the S6E2HG device. 

4. Run the program. 

5. Run the Serial Port Viewer, set the baud rate as 115200, and click the Disconnected 

button to connect the board with the PC, as described in section Run the Test Demo. 
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Figure 4-3: Select the Baud Rate 

 

 

6. Click the Toggle Outgoing Data Window button. 

Figure 4-4: Toggle the Outgoing Data Window 

 

7. Key in any characters in the Outgoing Data Window, the same characters will be echoed 

in the Input Data Window. 

Figure 4-5: Echo Test 
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4.2.5   Sleep Mode 

4.2.5.1 Project Description 

This project demonstrates the sleep mode operation of the S6E2HG device. The MCU will enter 

sleep mode after blinking the green LED 5 times. It can be woken up by pressing the SW3 key. 

After wakeup, the green LED will turn on. 

4.2.5.2 Hardware Connection 

No specific hardware connections are required for this project. All connections are hardwired on 

the board. 

4.2.5.3 Verify Output 

1. Power the FM4 S6E2G-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 

2. Open the project file in IAR Embedded Workbench or Keil µVision IDE from the following 

directory on your PC: 

 IAR project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_sleep_mode\IAR\s6e2hg_sleep_mode.eww. 

 Keil project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_sleep_mode\ARM\s6e2hg_sleep_mode.uvprojx. 

3. Build the project and download the code into the S6E2HG device. 

4. Run the program. 

5. The RGB LED (LED2) will blink 5 times (green color), and then the MCU enters sleep 

mode. 

Figure 4-6: MCU in sleep mode 

 

6. Press the SW3 key to wake up the MCU. 

7. The RGB LED (LED2) will glow with green color. 

4.2.6   Software Watchdog 

4.2.6.1 Project Description 

This project is to demonstrate the operation of the S6E2HG watchdog. The project demonstrates 

two different situations: when the watchdog is fed and when the watchdog is not fed. 

If the watchdog is enabled and the watchdog is fed in time, the program will run properly, and 

the RGB LED (LED2) will blink green. 
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If the watchdog is enabled, but not fed in time, the chip will reset, and the green LED will remain 

glowing. 

4.2.6.2 Hardware Connection 

No specific hardware connections are required for this project. All connections are hardwired on 

the board. 

4.2.6.3 Verify Output 

1. Power the FM4 S6E2H-Series Starter board from CN3 using a USB cable, refer to  

Figure 2-5. 

2. Open the project file in IAR Embedded Workbench or Keil µVision IDE from the following 

directory on your PC: 

 IAR project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_st_wdt\IAR\s6e2hg_st_wdt.eww. 

 Keil project: <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware 

\Demo Projects\s6e2hg_st_wdt\ARM\s6e2hg_st_wdt.uvprojx. 

3. Build the project and download the code into the S6E2HG device. 

4. Run the program.  

5. The RGB LED (LED2) will blink green. 

6. Stop the program, comment out the line of Swwdg_Feed(); in main.c, and click File > 

Save  

 

7. Repeat steps 3 to 4. 

8. The RGB LED (LED2) will glow green but will not blink. 

4.3   Flash Programming 

This section describes how to program the S6E2HG MCU using the FLASH MCU Programmer 

and how to program the CMSIS-DAP device using the FLASH USB DIRECT Programmer. 

4.3.1   Programming the S6E2HG using the FLASH MCU Programmer 

1. The FLASH MCU Programmer gets installed on your PC as part the Kit installer. Follow 

Install Software to install the kit. 

2. Make sure the jumpers on the FM4 S6E2H-Series Starter board are placed according to 

Table 4-4. 

Table 4-4: Jumper Settings for S6E2HG programming using FLASH MCU Programmer 

Jumper Position Description 

J2 Open Sets MB9AF312K to 3.3V.  

J3 Open Enable MB9AF312K CMSIS-DAP for debugging and programming purpose. 
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Jumper Position Description 

J5 Open Sets MB9AF312K (CMSIS-DAP) in run mode. 

J7 Closed Selects CMSIS-DAP as power source. 

J10 Open Sets S6E2HG in programming mode  

J15 Pin1 to Pin2 Sets S6E2HG to 3.3V. 

J18 Closed Sets S6E2HG in programming mode 

J19 Closed CMSIS-DAP virtual COM connection (SIN0 to pin 21 of MB9AF312K) 

J20 Pin1 to Pin2 CMSIS-DAP virtual COM connection (SOT0 to pin 20 of MB9AF312K) 

J21 Pin1 to Pin2 Sets the PE0 pin to MD1 mode  

3. Connect the USB cable to the CN3 port. 

4. Observe that the Power LED (LED5) is glowing green. 

5. Launch the FLASH MCU Programmer from Windows  

Start Menu > All Programs > Cypress > FLASH MCU Programmer > FM0+ FM3 FM4 

6. Select Target MCU as S6E2HG6G/E/F. 

7. Set Crystal Frequency to 4MHz. 

8. Select the Motorola-S format file or Intel-HEX format file to be programmed to FLASH 

memory in the MCU. 

Note: The HEX file selected in this example is the Test Demo firmware. 

9. Check the COM Port number in the Windows Device Manager. 
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10. Enter the Virtual COM Port listed in the Ports of Windows Device Manager in COM box in 

the Customize setting window (This window appears when the Set Environment button is 

clicked). 

 

11. Click on the Full Operation (D+E+B+P) button to start programming. 

 

12. Reset the S6E2HG device by pressing the reset button (SW1) on the board, and click OK. 

 

Note: Please click on Help for any issues or errors encountered during programming. 
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4.3.2   Programming the CMSIS-DAP (MB9AF312K) Device Using the FLASH USB DIRECT 

Programmer 

By default, the latest CMSIS-DAP firmware is programmed on the MB9AF312K. It is not required 

for the user to re-program firmware again before running the CMSIS-DAP debugger. Follow the 

steps below to update the firmware, if needed. 

1. The FLASH USB DIRECT Programmer gets installed on your PC as part the kit installer. 

2. Make sure the jumpers on the FM4 S6E2H-Series Starter board are placed according to 

Table 4-5. 

Table 4-5: Programming Jumper Settings for CMSIS-DAP programming 

Jumper Position Description 

J2 Open Sets MB9AF312K to 3.3V.  

J3 Open Enable MB9AF312K CMSIS-DAP for 

programming and debugging purpose. 

J5 Closed Sets MB9AF312K (CMSIS-DAP) in 

programmer mode. 

J7 Closed Selects CMSIS-DAP as power source. 

J10 Closed Sets S6E2HG in programming mode 

J15 Pin1 to Pin2 Sets S6E2HG to 3.3V. 

J18 Open Sets S6E2HG in run mode 

J19 Closed CMSIS-DAP virtual COM connection (SIN0 to 

pin 21 of MB9AF312K) 

J20 Pin1 to Pin2 CMSIS-DAP virtual COM connection (SOT0 

to pin 20 of MB9AF312K) 

J21 Pin2 to Pin3 Sets pin PE0 to drive the LED  

3. Connect the USB cable to the CN3 port. 

4. Observe that the Power LED (LED5) is glowing green. 

5. Launch the FLASH USB DIRECT Programmer from Windows  

Start Menu > All Programs > Cypress > FLASH USB DIRECT Programmer > 

USBDirect 

6. Select the Target MCU as MB9AF312K. 

7. Select the Motorola-S format file or Intel-HEX format file to be programmed on 

MB9AF312K. The hex file is included in the following directory: 

 <User_Directory>: 

\FM4 S6E2H-Series Starter Kit_Ver01\Firmware\CMSIS-DAP 
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8. Check the COM Port number in the Windows Device Manager. 

 

9. Enter the Virtual COM Port listed in the Ports of Device Manager in the COM box. 

10. Click the Full Operation (D+E+B+P) button to start programming. 
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11. Reset the CMSIS-DAP microcontroller by removing and reconnecting the USB cable, and 

click OK. 

 

12. Click OK button in Erase and Program Complete window. 

 

Note: Please click on Help for any issues or errors encountered during programming. 
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A. Appendix 

 

 

A.1 Schematic 

Figure A-1. MCU 
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Figure A-2. CMSIS-DAP & JTAG 
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Figure A-3. SD Card Interface 
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Figure A-4. NAND Flash (NOT MOUNTED) 
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Figure A-5. SDRAM (NOT MOUNTED) 
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Figure A-6: USB (NOT MOUNTED) 
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Figure A-7: Power 
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A.2 Bill of Materials 

Item Qty Reference Value Description Mfg Mfg part number 

1 1 CN1 2.54mm, 2pin,Wall 
2.54mm, 2pin 

connector 
AIMO 2285-0106ANGO01 

2 1 CN2 2.54mm, 10*2pin,Wall 
 2.54mm,10*2pin IDC 

connector 
AIMO 2285-0110ANGO01 

3 1 CN3 10118192-0001LF  Micro USB type B  FCI 10118192-0001LF 

4 4 CN5 SDSN09-A0-0015 SD card interface PROCONN SDSN09-A0-0015 

5 10 
J2, J3, J5, J6, J7, J8, 

J16, J10, J18, J19 
Pin header,1*2pin,dip 2.54mm, 2pin header AIMO 1225-1102ANGOS11.501 

6 3 J15, J20, J21 Pin header,1*3pin,dip 2.54mm, 3pin header AVX 1225-1103ANGOS11.501 

7 1 U2-1, U2-2 Pin header,30*2pin,dip 
2.54mm,30*2pin 

header 
AIMO 1225-11060ANGOS11.501 

8 27 

C1, C2, C3, C7, C9, 

C10, C11, C12, C13, 

C18, C19, C24, C26, 

C28, C29, C32, C33, 

C34, C35, C36, C37, 

C38, C39, C41, C42, 

C64, C65 

0.1uF Ceramic Capacitor YAGEO CC0603KRX5R8BB104 

9 4 C5, C21 220pF Ceramic Capacitor YAGEO CC0603JRNPO9BN221 

10 2 C6, C22 100nF Ceramic Capacitor YAGEO CC0603KRX5R8BB104 

11 0 C14, C15, C30, C31 NC/12pF Ceramic Capacitor YAGEO CC0603KKX5R8BB120 

12 2 C16, C17 12pF Ceramic Capacitor YAGEO CC0603JRNPO9BN120 

13 1 C62 10pF Ceramic Capacitor YAGEO CC0805KKX5R8BB100 

14 1 C63 1uF Ceramic Capacitor YAGEO CC0603KKX5R8BB105 

15 2 C20, C27 4.7uF Ceramic Capacitor YAGEO CC0603KKX5R8BB475 

16 2 C8, C23 10uF Ceramic Capacitor YAGEO CC0603KKX5R8BB106 

17 1 C4 10uF/16V Electrolytic Capacitor Panasonic EEE-FK1C100R 

18 1 C40 100uF/16V Electrolytic Capacitor Panasonic EEE-1CA101WP 

19 14 

RN1, RN3, RN4, RN5, 

RN6, RN7, RN8, RN9, 

RN10, RN11, RN12, 

RN13, RN14, RN16 

22R Resister Array BOURNS 652-CAT16-220J4LF 

20 2 RN15, RN17 10K Resister Array BOURNS 652-CAT16-103J4LF 
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Item Qty Reference Value Description Mfg Mfg part number 

21 4 R1, R78, R79, R80 1K Resister YAGEO RC0603FR-071KL 

22 14 

R2, R4, R15, R16, 

R18, R20, R38, R39, 

R40, R33, R51, R54, 

R84, R91 

10K Resister YAGEO RC0603FR-0710KL 

23 1 R5 510R Resister YAGEO RC0603FR-07510RL 

24 1 R6 680R Resister YAGEO RC0603FR-07680RL 

25 1 R7 220R Resister YAGEO RC0603FR-07220RL 

26 4 R8, R12, R13, R14 0R Resister YAGEO RC0603FR-070RL 

27 3 R10, R37, R83 1M  Resister  YAGEO RC0603FR-070RL 

28 3 R17, R22, R23 100R  Resister YAGEO RC0603FR-071ML 

29 10 

R24, R34, R35, R44, 

R45, R46, R47, R48, 

R49, R50 

22R  Resister YAGEO RC0603FR-0722RL 

30 5 
R29, R30, R70, R89, 

R90 
2K  Resister YAGEO RC0603FR-072KL 

31 1 R31 2K7  Resister YAGEO RC0603FR-072K7L 

32 0 
R26, R36, R52, R74, 

R75, R76, R77, R92 
NC  Resister YAGEO RC0603FR-070RL 

33 2 R41, R42 3K3  Resister YAGEO RC0603FR-073K3L 

34 1 R55, R88 6K8  Resister YAGEO RC0603FR-076K8L 

35 2 R81, R82 4R7  Resister YAGEO RC0603FR-074R7L 

36 2 R3, R32 10K  Resister YAGEO RC0603FR-0710KL 

37 1 R11 3386P-1-103T Potentiometer BOURNS 3386P-1-103T 

38 1 LED4 LED YELLOW  
Yellow 

LED,0805,SMT 
OSRAM LY R976-PS-36 

39 1 LED5 LED GREEN 
Green 

LED,0805,SMT 
OSRAM LG R971-KN-1 

40 2 LED1, LED3 LED RED Red LED,0805,SMT OSRAM LH R974-LP-1 

41 1 LED2 
CLV1A-FKB-

CJ1M1F1BB7R4S3 
RGB LED,SMT Cree 

CLV1A-FKB-

CJ1M1F1BB7R4S3 

42 2 D1, D4 DL4148 Rectifier Diode MMC DL4148 

43 3 FB2, FB3, FB4 MPZ1608S101AT Ferrite Bead TDK MPZ1608S101AT 

44 1 Q2 MMS8550-H-TP NPN transistor MMC MMS8550-H-TP 
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Item Qty Reference Value Description Mfg Mfg part number 

45 3 SW1, SW2, SW3 ELTSM-62KR-H-T/R 

Push- 

button,6*6*5mm, 

SMT 

Jinling ELTSM-62KR-H-T/R 

46 1 U1 
S6E2HG6G0A 

GV20000 

MCU,176LQFP,0.5m

m pitch 
Cypress S6E2HG6G0A GV20000 

47 1 U4 MB9BF312K 
MCU,64LQFP,0.5mm 

pitch 
Cypress MB9BF312KPMC 

48 1 U7 
LM1117IMPX-

3.3/NOPB 
Regulator TI LM1117IMPX-3.3/NOPB 

49 2 Y1, Y3 
CSTCR4M00G15L99-

*0 

Ceramic Resonator，

4M，1000ppm 
Murata CSTCR4M00G15L99-*0 

50 1 Y2 QRA-32768A20125B Crystal,32.768K,206 Wisdom QRA-32768A20125B 

 

 



 

FM4 S6E2H-Series Starter Kit Guide, Doc. No. 002-11387 Rev. ** 59 

 

Revision History 

 

 

Document Revision History 

Document Title: FM4 S6E2H-Series Starter Kit Guide 

Document Number: 002-11387 

Revision 
ECN 

Number 
Issue Date 

Origin of 

Change 
Description of Change 

** 5179566 03/24/2016 CCTA Initial revision. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  


